Welcome to the

MTN Community

Answered question

This usually happens when your iPhone's Message Notification is set on Repeat and there is network traffic, congestion on the sender's location or recipient's location. This signals the SMS to be resent automatically when congestion is over. The solution is to set your Device Message Notification to Never. Here's how to resolve it.

1. Launch Settings and scroll to Notifications

2. Tap on Messages

3. Tap on the options arrow on Repeat Alert and choose NEVER

Did you find this useful ?

No (0)

Yes (4)

100%

100% of users found this answer useful